安装Apache提示缺少 libapr-1.so.0与libaprutil-1完美解决

Advertisement

libpq.so.4

libpq.so.4的包属于:postgresql-libs-32bit-8.1.9-2.1.x86_64.rpm 在安装bind-sdb提示缺少该种依赖时需要安装。

libaprutil-1.so.0包属于:apr-util-1.2.7-2.i386 libapr-1.so.0 属于 apr-1.2.7-11.i386.rpm

linux RH5安装httpd提示libapr-1.so.0/libaprutil-1.so.0 is needed by httpd-2.2.3-11.el5.i386
linux RH5安装httpd提示
libapr-1.so.0 is needed by httpd-2.2.3-11.el5.i386
libaprutil-1.so.0 is needed by httpd-2.2.3-11.el5.i386

此提示是需要安装apr和apr-util的apm包,apr属于apr-1.2.7-11.i386.rpm,而apr-util属于postgresql-libs-8.1.9-1.el5.i386.rpm,安装这2个包就可以安装httpd的rpm包了。

安装Apache提示缺少 libapr-1.so.0与libaprutil-1完美解决

[[email protected] RHEL_5.5 i386 DVD]# cd Server[[email protected] Server]# ll | grep httpd
-r--r--r-- 152 root root 1275876 2010-03-09 httpd-2.2.3-43.el5.i386.rpm-r--r--r-- 177 root root 151877 2010-03-09 httpd-devel-2.2.3-43.el5.i386.rpm-r--r--r-- 152 root root 832734 2010-03-09 httpd-manual-2.2.3-43.el5.i386.rpm-r--r--r-- 616 root root 611542 2007-11-27 system-config-httpd-1.3.3.3-1.el5.noarch.rpm[[email protected] Server]# rpm -ivh httpd-2.2.3-43.el5.i386.rpm
error: Failed dependencies:
libapr-1.so.0 is needed by httpd-2.2.3-43.el5.i386
libaprutil-1.so.0 is needed by httpd-2.2.3-43.el5.i386
[[email protected] Server]#
到这里 出现错误了,要求要libapr-1.so.0和libaprutil-1.so.0这2个东东。这时需要apr文件
-----------------------------------------------------------------------------------------------
[[email protected] Server]# ll | grep apr
-r--r--r-- 433 root root 125992 2009-08-07 apr-1.2.7-11.el5_3.1.i386.rpm
-r--r--r-- 433 root root 237184 2009-08-07 apr-devel-1.2.7-11.el5_3.1.i386.rpm
-r--r--r-- 368 root root 543487 2009-08-07 apr-docs-1.2.7-11.el5_3.1.i386.rpm
-r--r--r-- 177 root root 81473 2010-03-04 apr-util-1.2.7-11.el5.i386.rpm
-r--r--r-- 177 root root 54478 2010-03-04 apr-util-devel-1.2.7-11.el5.i386.rpm
-r--r--r-- 152 root root 233456 2010-03-04 apr-util-docs-1.2.7-11.el5.i386.rpm
-r--r--r-- 152 root root 13907 2010-03-04 apr-util-mysql-1.2.7-11.el5.i386.rpm
-r--r--r-- 368 root root 9472 2007-01-19 xorg-x11-drv-dynapro-1.1.0-2.i386.rpm
嘿嘿,我们需要的文件是apr-1.2.7-11.el5_3.1.i386.rpm和apr-util-1.2.7-11.el5.i386.rpm
先安装一个看看
[[email protected] Server]# rpm -ivh apr-1.2.7-11.el5_3.1.i386.rpm
[[email protected] Server]# rpm -ivh httpd-2.2.3-43.el5.i386.rpm
error: Failed dependencies:
libaprutil-1.so.0 is needed by httpd-2.2.3-43.el5.i386
看到没有 至少一个文件libaprutil-1.so.0了,看来装下一个文件apr-util-1.2.7-11.el5.i386.rpm就可以了吧!
[[email protected] Server]# yum install apr-util-1.2.7-11.el5.i386.rpm 注意是yum安装哦 不然提示你少很多文件
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Examining apr-util-1.2.7-11.el5.i386.rpm: apr-util-1.2.7-11.el5.i386
Marking apr-util-1.2.7-11.el5.i386.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package apr-util.i386 0:1.2.7-11.el5 set to be updated
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
apr-util i386 1.2.7-11.el5 /apr-util-1.2.7-11.el5.i386 164 k
Transaction Summary
================================================================================
Install 1 Package(s)
Upgrade 0 Package(s)
Total size: 164 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : apr-util 1/1
Installed:
apr-util.i386 0:1.2.7-11.el5
Complete!
[[email protected] Server]# rpm -ivh httpd-2.2.3-43.el5.i386.rpm
Preparing... ########################################### [100%]
1:httpd #######################

ok http可以开始来安装了

Similar Posts:

  • Win7系统无法安装补丁提示缺少Service Pack系统组件的原因及解决方法

    最近很多网友说在win7系统电脑中无法安装不懂,提示"缺少Service Pack系统组件",引起win7提示"缺少Service Pack系统组件"的原因有很多种,针对此问题,下面本站的小编给大家介绍Win7无法安装补丁提示"缺少Service Pack系统组件"的原因和解决方法. Win7安装补丁失败缺少Service Pack系统组件解决方法: 一.无法安装Windows 7 SP1补丁包原因 Windows7优化大师中的系统清理功能里面,

  • 安装apache 提示APR not found ,pcre 解决方法

    安装apache 提示APR not found 解决方法 推荐方法,注意版本号. 1.下载apr安装包: http://labs.mop.com/apache-mirror//apr/apr-1.4.6.tar.gz tar zxvf apr-1.4.6.tar.gz cd apr-1.4.6 ./configure --prefix=/usr/local/apr make && make install 2.下载apr-util安装包: http://labs.mop.com/apac

  • CentOS用gem安装Mysql2提示缺少mysql.h

    环境: CentOS6 Ruby1.9.2 Rails3.0.10 在安装完了Mysql之后,用Gem安装Mysql2,提示以下错误: mysql.h is missing 运行以下命令即可解决: yum install mysql-devel 这个错误应该会多出现在红帽和CentOS中.

  • CentOS 6 64位上安装db2提示缺少 32 bit library file libstdc++.so.6

    1.执行db2_install的时候报了错,安装通过了,后来发现解压包下有个预检的脚本,拿来重新执行了下 [[email protected] lib64]# /server/db2prereqcheck WARNING: The 32 bit library file libstdc++.so.6 is not found on the system. 32-bit applications may be affected. 2.查看了db2prereqcheck,发现要进入到安装包下的子目录db2

  • Linux 编译安装 apache 2.4

    在安装apache之前需要准备一些必要的依赖包 gcc安装: #yum install -y gcc gcc-c++安装: #yum install gcc-c++ apr安装: 下载包:apr-1.5.2.tar.gz,然后tar解压缩到任意目录下.然后进入解压缩后的目录下进行如下编译: # ./configure --prefix=/usr/local/apr # make # make install apr-util安装: 下载包:apr-util-1.5.4,同样tar解压缩到任意目录

  • 安装libxml2提示:Python.h:No&nb…

    安装libxml2提示:Python.h:No such file or directory,如图 such file or directory" title="安装libxml2提示:Python.h:No such file or directory" /> 解决方法是:安装Python,一般Python都是装了的,可以rpm -q python,如果没装,装一下,如果还提示此问题,把python-devel也装一下,yum -y install python-de

  • centos6.0安装apache http sever 反向代理与集群

    kms亲测 安装环境: --------------------------- linux : cenos6.0 (验证4.8也会碰到以下问题) apache: httpd-2.4.6.tar.bz2 --------------------------- 安装前需准备文件: apr-1.4.6.tar.gz APR和APR-UTIL的下载地址:http://apr.apache.org/download.cgi apr-util-1.4.1.tar.gz pcre-8.30.zip 下载地址:

  • CentOS 4.4 编译安装 apache 2+php5+mysql 5+Zend Optimizer3.2.0+eaccelerator

    CentOS 4.4 编译安装 apache 2.2.3+php 5.2.0+mysql 5.0.27+Zend Optimizer v3.2.0+eaccelerator-0.9.5笔记 先声明,我绝对是个Linux的菜鸟,以下的这些文字个人的安装笔记,是参考了网上许多高手的成功经验组合而成的,说实话我自己的东西不多 :)我想把这些经验写下来,既可以对其他跟我一样摸索的兄弟一个经验,也可以防止以后自己都忘记了,嘿嘿. 所以如果某个大虾看到我借用了你的资源,请你不要生气.也欢迎大家进行指点. 1

  • Loadrunner:安装LR11时提示缺少vc2005_sp1_with_atl_fix_redist

    [问题现象] 安装LR11时提示缺少vc2005_sp1_with_atl_fix_redist: [解决办法] 手动安装缺少的组件,LR安装包中已自带该组件,为何不自动捕捉异常去获取该自带的组件去安装呢?体验不好....该组件在安装程序自带的lrunner\Chs\prerequisites\vc2005_sp1_redist,双击运行,再重新安装LR就可以了.

  • linux下安装apache出现警告libexpat.so.0, needed by问题的解决办法

    问题描述: 在安装apache的时候执行make,会报错: /usr/bin/ld: warning: libexpat.so.0, needed by /home/zhubin215130/download/httpd-2.2.11/srclib/apr-util/.libs/libaprutil-1.so, not found (try using -rpath or -rpath-link)h 出现原因: 认为可能是我犯贱升级了linux的某个组件,导致libexpat.so.0被升级成了

Tags: